«

»

Dec 07

The Great Conversion… (Part1)

Tonight I have started the process of converting my own CX300 to a CX3-20c.  (yay!  upgrading from SERIOUSLY out-of-date hardware to MODERATELY out-of-date hardware, right?)

Why?  Because it’s there.  Since EMC doesn’t offer free training to sub-sub-sub-contractors such as myself, it falls to me to learn what I can where I can. 

Besides.  It’s fun.

So far it’s been pretty simple.  Printed out the 63 page guide from the Clariion Proceedure Generator, and was briefly intimidated by it before I realized that 80% of it is completely useless.

But, because I want the experience, I’m going through each step of it.

First thing I did was backed up the vault pack.  This particular CX300 has no data on it, so it was a simple process to swap the five vault drives on at a time.  Though in the interest of doing it gracefully, I did bind a 1G lun across the five drives so that I could use the proactive sparing to gracefully remove each drive.  (The option isn’t available unless you have a bound lun on the raid group)

Obviously I want to come out of this with a working CX300 as well as the CX3-20. 🙂  (And of course my fear is ending up with not one but TWO doorstops at the end of this process)

Ran CRC2.  Interesting application, might come in handy in the future, because  when it comes down to it, it gives you a LOT of information about your clariion that you don’t get from the GUI.

Luckily this is a situation where there isn’t anything i need to keep on the array.  One thing stands out though, I had to delete the little 1G lun I bound on the vault pack to get the CRC2 check to pass, because apparently a number of the system partitions need to expand.  (Life would have sucked if I didn’t have the ability to wipe the drives)

After deleting the 1G lun, CRC2 passed and all was good with the world.

Skipped the next 6 pages, which describe how to make room in the rack for the new equipment.

Why?

No rack in my basement anymore, I guess a desk will do.

Let’s just say rack-space really isn’t the issue here. 😉

So the only thing I wasn’t able to find was a copy of EMCRemote.  Though I have an older one from back in my EMC days, hopefully the protocols haven’t changed much.  <crosses fingers>

So Unisphere Service Manager (Formerly Navisphere Service TaskBar) is installed, and the first step is to install the target platform conversion-prep software.  A pretty straight-forward install.  Once this package is installed you’re comitted. (or should be)

I had a bit of a worry loading the conversion-image, SPB didn’t come back before USM timed out…which seems like something that might just happen in these older, slower devices, right? 

The ConversionPrep, ConversionImage, and most importantly, the new Utility partition all seem to have installed correctly, as with the HSConversionB package. 

Now sadly, there are no descriptions as to what each NDU does, though logically:

ConversionPrep handles the settings – one of the things that you verify after the ConversionPrep is loaded is that write-cache is disabled (which it always was because I don’t have a SPS cable for this model) and such.

ConversionImage and Utility Partition are pretty self-explanitory, the CX3 looks for things in different places, requires different drivers, etc. 

HSConversionB was the stumper.  HardwareSwap?  Any ideas?

Last step was to shut-down the array.  This will be my stopping point. 

Stay tuned, same bat-time, same bat-rss-feed.

4 comments

Skip to comment form

  1. self storage software

    i cant wait to read part 2.

    1. Jesse

      I’m hoping to get back to the project sometime next spring. 😉

  2. James

    Do you have the flare os on a dae2 with cx300’s to actually be able to use it? I would like to buy one for cheap on ebay just to hook up directly with an hba card to a server. I’m worried it will be useless if does not have the flare os installed. Is it possible just to install the flare os on it?
    thanks

    1. Jesse

      Sort of.

      I do – but my misconception that this was a CX3-20C and not a CX3-10C was key.

      You can upgrade *TO* a CX3-20C from a CX300, you cannot upgrade to a CX3-10C from a CX300. So much fail in one day. (Not how long it has taken to update this)

      Ironically, today is the day I make payment on another CX3-10C on Ebay, once I clone the vault-drives, I’ll have two. 🙂

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>